0

Vufind und PHP 5.3

Posted by Oliver Goldschmidt on 12. Oktober 2010 in vufind |

Vufind läuft laut Systemvoraussetzungen unter PHP 5.2. Ich habe gerade mal probiert, was passiert, wenn man es unter PHP 5.3 laufen lässt. Ergebnis: laufen kann es, ABER

  1. es gibt diverse Warnungen über veraltete Pear-Module, die von vufind genutzt werden
  2. Feldauswahl und Facettierung verweigern den Dienst

So ist eines der schönsten Features von Vufind, die Facettierung, nur unter PHP 5.2 nutzbar. Falls jemand andere Erfahrungen gemacht hat, würde ich mich über Kommentare freuen!

[UPDATE] Nach einem kurzen Mailwechsel auf vufind-tech haben wir den Fehler gefunden: Schuld war die striktere Behandlung von Konfigurationsdateien unter Version 5.3. Eine syntaktisch nicht korrekte Zeile (ExpandFacets:[ini section]:[ini name]) in der searches.ini war nicht auskommentiert. Dies verhindert unter PHP 5.3, dass die Datei geladen wird. Alle Konfigurationsoptionen aus der Datei standen demzufolge nicht zur Verfügung.
Vufind an sich ist also doch auch unter PHP 5.3 vollständig lauffähig. Nur die Warnungen über veraltete PEAR-Module kriegt man nicht weg, solange diese nicht an PHP 5.3 angepasst werden.

Schlagwörter: , , , ,

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.

*

Copyright © 2010-2019 tub.find Blog All rights reserved.
This site is using the Desk Mess Mirrored theme, v2.5, from BuyNowShop.com.